Hallo, Gast
Sie müssen sich registrieren bevor Sie auf unserer Seite Beiträge schreiben können.

Benutzername
  

Passwort
  





Durchsuche Foren

(Erweiterte Suche)

Foren-Statistiken
» Mitglieder: 149
» Neuestes Mitglied: clemenz
» Foren-Themen: 776
» Foren-Beiträge: 1,225

Komplettstatistiken

Benutzer Online
Momentan sind 68 Benutzer online
» 0 Mitglieder
» 67 Gäste
Bing

Aktive Themen
Welches Gästebuch wählen?
Forum: Off Topic
Letzter Beitrag: Coreycliew
26.07.2020, 00:48:19
» Antworten: 10
» Ansichten: 21,880
PHP Standard-Version auf ...
Forum: Ankündigungen
Letzter Beitrag: ok-webhosting
15.07.2019, 18:12:14
» Antworten: 0
» Ansichten: 10,483
AllowOverride-Option "Fil...
Forum: Ankündigungen
Letzter Beitrag: ok-webhosting
13.02.2019, 09:52:10
» Antworten: 0
» Ansichten: 11,422
Hinweise zur EU-Datenschu...
Forum: Ankündigungen
Letzter Beitrag: ok-webhosting
16.05.2018, 19:58:58
» Antworten: 0
» Ansichten: 5,767
Roundcube Update auf Vers...
Forum: Ankündigungen
Letzter Beitrag: ok-webhosting
30.01.2016, 13:24:31
» Antworten: 0
» Ansichten: 4,410
Joomla :: mehrere Sicherh...
Forum: Security
Letzter Beitrag: ok-webhosting
16.12.2015, 07:37:02
» Antworten: 0
» Ansichten: 10,076
vBulletin :: Sicherheitsp...
Forum: Security
Letzter Beitrag: ok-webhosting
04.11.2015, 20:18:21
» Antworten: 0
» Ansichten: 2,835
Joomla! >= 3.0.0 <= 3.4.4...
Forum: Security
Letzter Beitrag: ok-webhosting
23.10.2015, 16:42:49
» Antworten: 0
» Ansichten: 3,520
xt:commerce :: Sicherheit...
Forum: Security
Letzter Beitrag: ok-webhosting
27.05.2015, 08:23:09
» Antworten: 0
» Ansichten: 3,181
SSH-Client Putty :: Troja...
Forum: Security
Letzter Beitrag: ok-webhosting
20.05.2015, 05:27:53
» Antworten: 0
» Ansichten: 2,776

 
  PHP Standard-Version auf PHP 7.2 angepasst
Geschrieben von: ok-webhosting - 15.07.2019, 18:12:14 - Forum: Ankündigungen - Keine Antworten

Sehr geehrte ok-webhosting Kunden,

bitte beachten Sie dass die PHP Standard-Version in LiveConfig auf PHP 7.2 gesetzt wurde. D.h ohne Ihr Zutun werden künftig neu angelegte Domains/Subdoamins PHP Version
7.2 nutzen.


Selbstverständlich lassen sich aber darüber hinaus wie gewohnt für jede Domain/Subdomain einzeln die PHP-Versionen 5.3 / 5.6 / 7.0 / 7.1 / und 7.3 in LiveConfig auswählen.

ACHTUNG !!!

Vom Einsatz von PHP 5.3 und PHP 5.6 wird ausdrücklich abgeraten, diese Versionen finden auf dem Server aus Sicherheitsgründen in absehbarer
Zeit keine Unterstützung mehr. Scripte die lediglich noch unter PHP 5.3 oder 5.6 lauffähig sind sollten daher dringend!!! ersetzt oder überarbeitet werden.

Für bereits angelegte Domains und Subdomains ändern sich die bislang genutzten PHP-Versionen (dies wird meist der bisher auf dem System
gesetzte Standard, PHP 7.0 sein) zunächst nicht. Sofern PHP 7 genutzt wird, werden diese im LiveConfig allerdings nun als PHP 7.2 (Standard) angezeigt.
Tatsächlich wird PHP 7.2. aber erste genutzt wenn manuell kurz auf eine andere PHP-Version und danach auf PHP 7.2. zurück gestellt wird.


Die PHP-Versionen lassen sich jeweils für jede Domain/Subdomain im LiveConfig aktivieren (empfohlene Methode) oder für einzelne
Verzeichnisse durch eine htaccess mit dem Inhalt

FcgidWrapper /var/www/xwebX/conf/php53/php-fcgi-starter .php

anpassen.

xwebX und php53 sind entsprechend auf den Einzelfall anzupassen xwebX ist durch das Nutzerverzeichnis zu ersetzen, also zum
Beispiel pweb5 und php53 durch die gewünschte Version, php53 = PHP 5.3 / php56 = PHP 5.6 usw.

Letzteres Methode über die htaccess wir jedoch nur empfohlen sofern unbedingt notwendig, d.h wenn tatsächlich andere Verzeichnisse der
selben Domain/Subdomain andere PHP-Versionen benötigen, ansonsten wäre die Aktivierung über LiveConfig die zu bevorzugende Art der Umstellung.


Sollten Sie noch Fragen haben jederzeit gerne.

Drucke diesen Beitrag

  AllowOverride-Option "FileInfo" aus Apache entfernt
Geschrieben von: ok-webhosting - 13.02.2019, 09:52:10 - Forum: Ankündigungen - Keine Antworten

Sehr geehrte Damen, sehr geehrte Herren, liebe ok-webhosting Kunden,

um die Sicherheit unserer Systeme weiter zu erhöhen wurden die AllowOverride-Option "FileInfo" in allen Apache vhost-Konfigurationen entfernt und statt dessen wurden die erlaubten Anweisungen in AllowOverrideList aufgeführt. Die Anweisung "SetHandler" wird damit nicht mehr in .htaccess-Dateien erlaubt sein.

Web-Anwendungen benötigen in der Regel keine SetHandler-Anweisung in der .htaccess. Eine Ausnahme stellt hier leider Drupal dar: dort enthält u.a. /sites/default/.htaccess entsprechende SetHandler-Anweisungen, um die Ausführung von hochgeladenen Dateien zu verhindern.


Wo notwendig wurden durch uns die entsprechenden htaccess-Dateien bereits angepasst, so dass durch Sie in der Regel nichts weiter zu veranlassen sein wird. Weitere Informationen zur .htaccess-Thematik bei Drupal finden Sie unter https://hostinghandbuch.de/apps.drupal.htaccess

Bei Fragen stehen wir gerne zur Verfügung.

Drucke diesen Beitrag

  Hinweise zur EU-Datenschutz-Grundverordnung (DSGVO)
Geschrieben von: ok-webhosting - 16.05.2018, 19:58:58 - Forum: Ankündigungen - Keine Antworten

Sehr geehrte Damen, sehr geehrte Herren, liebe ok-webhosting Kunden,

aufgrund zahlreicher fernmündlicher Anfragen der letzten Tage, die wir leider nicht alle persönlich beantworten konnten, anbei einige Informationen zur Datenschutz-Grundverordnung (DSGVO).

Wenn wir für Sie personenbezogene Daten als Auftragsverarbeiter nach Art. 28 DSGVO (Datenschutzgrundverordnung) verarbeiten, sollten Sie mit uns eine entsprechende Vereinbarung zur Auftragsverarbeitung abschließen. Bitte prüfen Sie, ob Sie mit den von uns bereitgestellten Leistungen personenbezogene Daten im Sinne der DSGVO verarbeiten. Sollte dies der Fall sein, schließen Sie bitte diese Vereinbarung mit uns ab.

Wir lassen Ihnen eine Auftrag zur Auftragsdatenverarbeitung gerne per Email zukommen, hierzu genügt eine kurze Nachricht an datenschutz@ok-webhosting.de

!!! Bitte beachten Sie in diesem Zusammenhang, dass ab dem 19.05.2018 bis zum 30.05.2018 wegen urlaubsbedingter Abwesenheit nur unaufschiebbare Supportanfragen bearbeitet werden !!!

Hinsichtlich der Bestimmungen der DSGVO kann es unter anderem auch notwendig sein auf Ihrer Präsenz eine SSL-Zertifikat einzusetzen. Vor diesem Hintergrund bieten wir unseren Bestandskunden selbstverständlich den kostenfreien Umzug auf eines unserer neuen Systeme an. Accounts von Kunden mit einer Kundennummer größer als 11000 befinden sich bereits auf einem unserer neuen Systeme, wie Sie dort ein entsprechendes SSL-Zertifikat beantragen und installieren, entnehmen Sie bitte dem Account-Handbuch dass Ihnen mit Freischaltung Ihres Accounts auf dem neuen System zugegangen ist.

Sie finden diese aber auch jederzeit unter https://ok-webhosting.de/anleitungen/Han...Config.pdf zum Download.

Neben weitere Vorzügen wie deutlich erhöhte Ressourcen zu gleichbleibenden Konditionen, frei wählbare PHP-Versionen je Domain/Subdomain/Verzeichnis/, PHP als FastCGI gibt es für Accounts auf den neuen Systemen im Sinne der "fair use Policy" auch keine Trafficbeschränkung mehr. Die Konditionen bleiben hingegen unverändert.

Darüber hinaus besteht u.a. mit dem SSL-Self Modul die Möglichkeit der kostenlosen Nutzung von SSL-Zertifikaten des Anbieters Let's Encrypt für alle Ihre Domains/Subdomains (ab dem Beginner-Account ist SSL-Self bereits inclusive).

Sollten Sie an einer Migration auf eines unsere neuen Systeme Interesse haben bitten wir um kurze Nachricht an support@ok-webhosting.de und werden Ihnen dann alle weiteren Informationen zukommen lassen.

Weitere Informationen zur DSGVO finden Sie zum Beispiel unter https://de.wikipedia.org/wiki/Datenschut...verordnung.

Drucke diesen Beitrag

  Roundcube Update auf Version 1.0.8
Geschrieben von: ok-webhosting - 30.01.2016, 13:24:31 - Forum: Ankündigungen - Keine Antworten

Sehr geehrte ok-webhosting Kunden,

aufgrund einer bekannt gewordenen Sicherheitslücke vor Roundcube Version 1.0.8 wurde Roundcube 1.0.4
auf unseren Systemen auf die fehlerbereinigte Version 1.0.8 upgedatet.

Drucke diesen Beitrag

  Joomla :: mehrere Sicherheitslücken in Joomla bis Version 3.4.5 (3.4.6 / siehe Update)
Geschrieben von: ok-webhosting - 16.12.2015, 07:37:02 - Forum: Security - Keine Antworten

Technische Warnung des Bürger-CERT
----------------------------------

TECHNISCHE WARNUNG TW-T15/0116
Titel: Sicherheitsupdate für Joomla!
Datum: 15.12.2015
Risiko: hoch

ZUSAMMENFASSUNG
Joomla! schließt mit dem aktuellen Sicherheitsupdate mehrere
Sicherheitslücken, die es einem Angreifer aus dem Internet ermöglichen,
beliebige Befehle einzuschleusen und auszuführen und damit erheblichen
Schaden auf dem betroffenen Joomla!-System anzurichten.

BETROFFENE SYSTEME
- Joomla!
- Joomla! ab 1.5.0
- Joomla! bis einschließlich 3.4.5

EMPFEHLUNG
Aktualisieren Sie Joomla! über die referenzierte Download-Seite so
schnell wie möglich auf die Version 3.4.6.

BESCHREIBUNG
Joomla! ist ein Content Management System, mit dem Webauftritte und
Internet-Anwendungen erstellt werden können. Es ist einfach zu benutzen
und zu erweitern. Die Software steht unter einer Open Source Lizenz und
ist frei verfügbar.

Joomla! schließt mehrere Sicherheitslücken im Joomla! Content Management
System, die vom Hersteller als kritisch eingestuft werden und die bereits
aktiv für Angriffe ausgenutzt werden.

QUELLEN
- Joomla! Download-Seite
<https://www.joomla.org/download.html>
- Heise Security: Joomla-Version 3.4.6 stopft kritische Sicherheitslücke
<http://www.heise.de/security/meldung/Joo...43699.html>


ACHTUNG !!! Wichtiges Update:

Die veröffentlichte Version 3.4.6 lässt leider immer noch Angriffe auf Joomla-Installationen zu. Erst Version 3.4.7 soll die Lücke nun endgültig schließen.

In den Joomla-Versionen 1.5 bis 3.4.6 klafft eine kritische Lücke, über die Angreifer Schadcode einschleusen können. Eigentlich sollte bereits das Update auf Version 3.4.6 das freie Content-Management-System absichern.

Nutzer sollten die aktuelle Joomla-Version so schnell wie möglich einspielen. Es gibt bereits einen Exploit der laut Sicherheitsforschern auch bereits genutzt wird.

Den Entwicklern zufolge enthält Version 3.4.7 nur das Sicherheitsupdate und keine neuen Funktionen. Zudem wird noch eine SQL-Injection-Lücke geschlossen, die die Entwickler mit dem Schweregrad leicht einstufen. Nutzer der Joomla-Versionen 1.5 und 2.5 steht der Patch zum entfernen der kritischen Lücke demnach ebenfalls zur Verfügung.

Drucke diesen Beitrag

  vBulletin :: Sicherheitsprobleme, Passwörter und Kundendaten gehackt
Geschrieben von: ok-webhosting - 04.11.2015, 20:18:21 - Forum: Security - Keine Antworten

Hacker haben sich Zugriff auf Passwörter und Kundendaten von vBulletin verschafft. Die vermeintlichen Täter behaupten, es existiere eine
kritische Sicherheitslücke in den vBulletin-Versionen 4.x und 5.x

Dringende Empfehlung:

Nutzer von vBulletin sollten sich auf der Seite der Autoren über den Fortgang des Sachverhalts informieren sowie zu gegebener Zeit zur Verfügung gestellte Sicherheitsupdates installieren. Darüber hinaus sollte geprüft werden in wie weit die nach derzeitigem Stand gehackten Kundendaten/Passwörter ein Handeln notwendig machen.

Entsprechende Berichte finden sich zahlreiche im Internet zum Beispiel unter
http://www.heise.de/security/meldung/Nac...eitrag.rdf

Drucke diesen Beitrag

  Joomla! >= 3.0.0 <= 3.4.4 :: Mehrere Schwachstellen ermöglichen das Ausführen beliebigen Programmcodes
Geschrieben von: ok-webhosting - 23.10.2015, 16:42:49 - Forum: Security - Keine Antworten

Mehrere Schwachstellen in Joomla! bis einschließlich Version 3.4.4 ermöglichen entfernten, nicht authentifizierten Angreifern das Einschleusen und Ausführen beliebiger SQL-Befehle, wodurch die Übernahme des Joomla!-Systems möglich wird, und das Umgehen von Sicherheitsmechanismen, so dass Informationen ausgespäht werden können.

Entsprechende Schwachstellen werden bereits aktiv ausgenutzt.

Der Hersteller hat die Version 3.4.5 als Sicherheitsupdate zum Download zur Verfügung gestellt.

Joomla! Sicherheitsupdate Version 3.4.5
Joomla! Download-Seite

Drucke diesen Beitrag

  xt:commerce :: Sicherheitslücke ermöglicht SQL Injection
Geschrieben von: ok-webhosting - 27.05.2015, 08:23:09 - Forum: Security - Keine Antworten

In der Shop-Software xt:Commerce klafft eine Sicherheitslücke, die sich zum Einschleusen von SQL-Befehlen ausnutzen lässt (Details sind der Entwickler-Seite unter http://www.xt-commerce.com/blog/xtnews/s...-1-00.html zu entnehmen). Indizien, die darauf hindeuten, dass die Lücke bereits aktiv ausgenutzt wurde,
gibt es derzeit nicht.

Für Abhilfe sorgen die abgesicherten Versionen 4.2.00, 4.1.10 und 4.1.00.

Drucke diesen Beitrag

  SSH-Client Putty :: Trojaner-Version im Umlauf
Geschrieben von: ok-webhosting - 20.05.2015, 05:27:53 - Forum: Security - Keine Antworten

Über den Secure-Shell-Client (SSH) Putty greift man über eine verschlüsselte Verbindung auf entfernte Geräte zu. Das Tool ist Open
Source und kostenlos verfügbar. Wie Symantec in seinem Blog berichtet ist jedoch aktuell eine Trojaner-Version im Umlauf, die Computer ausspioniert.

Die verseuchte Version von Putty sei daran zu erkennen, dass die Datei deutlich größer als die offizielle Version (512 Kilobyte) ausfällt.
Zudem sollten Virenscanner mit aktuellen Signaturen den Schädling erkennen. Wer Putty aus einer dubiosen Quelle installiert hat, sollte
das About-Fenster aufrufen. Steht dort „Unidentified build, Nov 29 2013 21:41:02“, handelt es sich dabei um die Version mit Schadcode.

Weitere Infos für interessierte Kunden sind bei Symantec (englisch) http://www.symantec.com/connect/blogs/ch...nformation
oder Heise Security (deutsch) http://www.heise.de/newsticker/meldung/S...eitrag.rdf nachzulesen.

Drucke diesen Beitrag

  Kritische Sicherheitslücke im FTP-Server ProFTPD
Geschrieben von: ok-webhosting - 19.05.2015, 18:48:20 - Forum: Security - Keine Antworten

Wie unter heise.de berichtet wird klafft derzeit in alle ProFTPD-Versionen eine Sicherheitslücke die es einem Angreifer erlaubt beliebigen Code einzuschleusen und auf Dateien außerhalb freigegebener Verzeichnisse zu zugreifen.
Die Schwachstelle soll wohl bereits durch entsprechende Exploits ausgenutzt werden, die im Netz zum Download bereit stehen
Zwar nutzt auch ok-webhosting ProFTPD allerdings ist dort bereits standardmäßig seit jeher das Modul mod_copy, dass o.g. Sicherheitslücke beinhaltet, deaktiviert, so dass die Sicherheitslücke nach derzeitigem Kenntnisstand nicht von belang ist.
Selbstverständlich werden wir jedoch bei Erscheinen der überarbeiteten ProFTPD-Version diese unbeachtet dessen installieren.
Weitere Informationen können interessierte Kunden bei Bedarf unter http://www.heise.de/newsticker/meldung/A...52114.html nachlesen

Drucke diesen Beitrag